VMware ESXi 的VLAN支持

  ESXi主机和交换机用trunk连接,在vSphere Client的主机网络配置中,虚拟机端口组的VLAN ID留空则虚拟机只可访问native VLAN (这里是VLAN 1);如果填写了ID则虚拟机只可访问对应的VLAN;如果ID填写4095则透传trunk,由虚拟机OS来完成VLAN区分(如PROSet)。

以上配置在此环境下测试通过:服务器为IBM X3650,安装ESXi 4.0.0 193498,双网卡均直接连接到6506的WS-X6748-GE-TX,IOS版本:s72033_rp Software (s72033_rp-ADVIPSERVICESK9_WAN-VM), Version 12.2(33)SXI, RELEASE SOFTWARE (fc2)
所有和ESXi主机相连的端口配置如下:
interface GigabitEthernet4/1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

3 thoughts on “VMware ESXi 的VLAN支持 Add Yours?

  • Dear Sir:
    目前加设好ESXi 4.0,不过现在遇到了一点问题,我们内部有设多个Vlan,目前要使这一台VM Server的guest可以跨Vlan联机,但一直设不出来。
    环境:
    两张网卡,一张设固定ip,另一张网卡设trunk。
    目前在vSpere Client中的Configuration,networking,可以看到一个是1000 full,另一个是Standby。
    guest os设定和ESXi server同网段就可以通,设不同网段就不能通。
    若我两个皆设Trunk,ESXi Server完全Ping不到。
    Vlan ID=4095(All),还有那边没有设定到吗?
    谢谢。

    Cisco-65091000full
    interface GigabitEthernet1/6
    description T2FNNMAP02
    switchport
    switchport access vlan 204
    switchport mode access
    switchport nonegotiate
    no ip address
    spanning-tree portfast
    end

    Cisco-3750 Standby
    interface GigabitEthernet1/0/7
    description T2FNNMAP02
    switchport trunk encapsulation dot1q
    switchport mode trunk
    end

    • 两个物理网卡连接交换机都设置为trunk,在vSpere Client中vSwitch0的网卡绑定中把两个网卡都激活,这样可以网络冗余,如果你的ESXi Server只有两个网卡建议这么设置。
      设置Management Network的属性,在Vlan ID中填写204,这样两个网卡都Trunk的时候就能访问ESXi Server了,这个也可以在控制台上面改。
      然后这个时侯你的guest os的网卡可以分属不同的端口组访问不同的vlan,或者是4095端口组直接访问trank

      造成你现在遇到问题的原因是,活动的那个网卡不是trunk,只能访问vlan204,所以guest os也不可能访问除了204以外的其它vlan。

  • hi,我用的ESXi4.1。有个奇怪的问题,有3个guest OS(虚拟机),分别为gOS1、gOS2、gOS3,分别属于vlan1、vlan1、vlan2,Management

    Network是vlan3,ESXi连接交换机(三层交换机,vlan间可互访)是trunk,实体的OS11、OS22、OS33,分别属于vlan1、vlan2、vlan3,现在

    问题是gOS1可以与gOS2、OS11、OS22、OS33互访,但gOS1就是不能与gOS3互访。就是说ESXi4.1的guest OS可以和不同vlan(有三层交换机)的

    实体机互访,同一vlan的guest OS可以互访,但就是不能在不同vlan间的guest OS互访。请问是哪里配置错了?

发表评论

电子邮件地址不会被公开。 必填项已用*标注

*

code

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据